Board index Flathead Power-Technical Questions, Answers, and Suggestions Knuckles Help with carb tunining on a Blown Knuckle

Help with carb tunining on a Blown Knuckle

Moderators: Curt!, Pa


Posts: 726
Location: nekoosa,wisconsin,usa

A few days ago I posted a short video of the start-up of Black Betty with the newly added Eagle Motor Company supercharger. Since then I had made some minor adjustments on the clutch pedal angle and shifter linkage. The first rides were then taken. The bike starts very easily with the use of the snowmobile plunger type primer. One or two squirts and she fires right up. Cold idle requires about 1200 rpm. Once warm 1100 is all drop in rpm the motor will take before starting to stall. I can live with that. Off idle response is another thing. Spit and sputter seems to be the watch word. I added a Thunder jet and tunable air bleed several years ago when I first ran the blower on the bike. Steady application of the throttle with the accelerator pump shut off at slow speeds brings this break-up that I spoke of. The indications that I'm getting don't fit the standard indicators ( Popping in the carb- lean, Exhaust popping and lazy throttle response maybe ) So in response I went from .031 to .030 and down to .295 with no change. Then I moved up to .032 , again no change. I haven't checked for manifold leaks yet. That will be my next move. Barring a vac/press. leak, what suggestions have you guys for me ?
BTW the 750 pixel limit sucks the bag !


Posts: 150
Location: Carver, MN

Let me give you a slightly educated guess. The jetting sounds way too lean to me. Boost requires way more fuel to go with the extra air it provides. The high idle could be a symptom of that. When jetting "from scratch" its always a good idea to make large changes so that you get a clear indication of whether you are going in the right direction or not. I'd try either a 36 or 40 intermediate to see what it does. If you find it wanted more fuel, don't forget to rejet the main!

Now here's my disclaimer. I have never tuned a carbureted blower bike, however I did have a supercharged Knuckle drag bike with electronic fuel injection. I had to add an extra pair of injectors to provide enough gas for that.

Good luck - can't wait to see it on the road!


Posts: 726
Location: nekoosa,wisconsin,usa

Thanks Lee,
I guess that sometimes I have to be told twice. I had Zippers install the Thunder Jet. They recommended a .035 for intermediate. When I started the motor, I was getting black smoke when I jacked the the throttle. I shut the acc. pump off, but still seemed rich. I have a .036 on the bench. It'll go in and I'll try it as soon as the rain quits.
John


Posts: 150
Location: Carver, MN

The very first hopped up Evo motor that I ever jetted with a Super B carb (back in the '80s) gave every indication of being rich (black smoke!) I kept going leaner on the intermediate to no effect. Finally someone clued me in that if the intermediate was significantly too small, the engine would draw off the main jet at low RPMs giving the symptoms of being rich. Sure enough a larger intermediate cleared up the black smoke. I don't think I've ever run into that specific issue since, but I'd guess that's whats going on with yours.


Posts: 726
Location: nekoosa,wisconsin,usa

My good friend Al Schumann is a tech support guy at S&S Cycle. I called him on Monday and told him of my dilemma. He asked me to send him images. ( no 750 pixel limit on his e-mail !) His diagnosis was that because of the bowl vent hole and air bleed that Zippers installed along with the Thunder Jet was in being flooded with air turbulence , the carb was breaking up. I shrouded both and voila a fix from Viola ! Black Betty now RUNS. Thanks Lee and all for your help.
John


Posts: 2684
Location: Los Angeles, CA
john k. endrizzi wrote:
BTW the 750 pixel limit sucks the bag !



John,
I have good luck uploading my photos to my free photobucket account. Then I paste the photobucket "IMG Code" here and all works well.


Posts: 726
Location: nekoosa,wisconsin,usa

Chris,
You have come a long way from the days when I was on this watch. As I recall you didn't have a clue on re-sizing and posting images. The image that i tried to post was one from my Photo Bucket account. Lets see if it bounces again.
Sure enough, here is the error message that I got now and before.
Your images may only be up to 700 pixels wide.


Posts: 2684
Location: Los Angeles, CA
I still don't have a clue about resizing. That is why I use photobucket. :D


Return to Knuckles