FAQ  •  Register  •  Login

oil pump issues???

Moderators: Curt!, Pa

<<

COOKY6660

Posts: 22

Joined: Mon Mar 09, 2009 3:55 pm

Post Mon Apr 18, 2011 3:44 pm

oil pump issues???

Hi can someone please guide me in the right direction. Ive just completed rebuilding my 38 1200 ul motor. I cant get the oil light to go out. Ive kicked and kicked! I must have a air lock somewhere i think. I forced air down the feed pipe and the pressure light will go out then. Ive filled the oil filter up with oil and the oil lines but to no avail. The oil pump seems ok, light went out before engine was rebuilt,
Any help would be greatfully appreciated
cooky...................
<<

Pa

Site Admin

Posts: 4650

Joined: Sun Mar 12, 2000 1:01 am

Location: Ohio USA

Post Mon Apr 18, 2011 4:47 pm

Re: oil pump issues???

Are you using an aftermarket oil sending unit switch or an oem one ? The aftermarket ones need more pressure than the pump puts out to knock the light off. Pa
<<

COOKY6660

Posts: 22

Joined: Mon Mar 09, 2009 3:55 pm

Post Mon Apr 18, 2011 11:27 pm

Re: oil pump issues???

Iam using after market switch but it was ok before engine rebuild? this is why i cant understand it?
<<

jib

Posts: 570

Joined: Sat Dec 10, 2005 3:36 pm

Location: devon,england

Post Tue Apr 19, 2011 3:13 am

Re: oil pump issues???

try taking switch off ,kick over till oil comes out of gallery hole,then replace switch.
Dude, check out that jibhead, he's crazy. Hasn't been sober for 40 years
<<

Pa

Site Admin

Posts: 4650

Joined: Sun Mar 12, 2000 1:01 am

Location: Ohio USA

Post Tue Apr 19, 2011 4:51 am

Re: oil pump issues???

COOKY6660 wrote:Iam using after market switch but it was ok before engine rebuild? this is why i cant understand it?


What pound pressure rate did the aftermarket switch trip before the rebuild ?
<<

COOKY6660

Posts: 22

Joined: Mon Mar 09, 2009 3:55 pm

Post Tue Apr 19, 2011 10:22 am

Re: oil pump issues???

Hi again
Sorted the problem today. Primed all the pipes again, took out pressure switch, kicked over. Fitted back everything started motor and oil light went out straight away. Thank heavens!! Motor sounds real sweet. Thanks for all the replies. This site is a godsend
regards
cooky
<<

Pa

Site Admin

Posts: 4650

Joined: Sun Mar 12, 2000 1:01 am

Location: Ohio USA

Post Tue Apr 19, 2011 9:00 pm

Re: oil pump issues???

Just what jib said ! Burp the little one and he will spit out. :lol:
<<

jib

Posts: 570

Joined: Sat Dec 10, 2005 3:36 pm

Location: devon,england

Post Wed Apr 20, 2011 2:52 am

Re: oil pump issues???

thanks pa but thats no credit to me as its out of the manual , just that i do it every time so its become a habit , :)
Dude, check out that jibhead, he's crazy. Hasn't been sober for 40 years

Return to Big Twin Flatties

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007, 2012 phpBB Group.