FAQ  •  Register  •  Login

UL 40`s valve covers....

Moderators: Curt!, Pa

<<

yp

Posts: 158

Joined: Sat Mar 29, 2003 1:01 am

Location: athens,greece

Post Mon Apr 10, 2006 11:45 am

UL 40`s valve covers....

Hi there,the rebuild of my U engine,tranny has finished at last......its running great so far(150miles)but i cannot get the the valve covers to seal,all the parts are good used oem ,but the springs are new.....i tapped them down onto the cork washer with the front of a screw driver gently a couple of times but this did`nt help....is there any tricks???could they need more miles to sit right???any help would be great......Thanks....
<<

JohnR

Posts: 146

Joined: Sat Nov 13, 1999 1:01 am

Location: Utah,USA

Post Mon Apr 10, 2006 6:44 pm

<<

steph

User avatar

Posts: 630

Joined: Fri Feb 21, 2003 1:01 am

Location: belgium

Post Tue Apr 11, 2006 12:38 am

YP you probably know but ... did you flatten the bottom cups(that hold the cork)so they sit flat on the gasket, when you assemble for the first time put the corks(inner tube cork also) in hot oil/water so they get flexible , or just change the corks for O-rings.
Mine is staying clean with the O-rings.
Stéph
<<

Frankenstein

User avatar

Posts: 1543

Joined: Thu Jun 27, 2002 12:01 am

Location: Interlaken, NY USA

Post Tue Apr 11, 2006 11:07 am

I switched to o rings some years ago also. It stays pretty dry. If it's reallyl blowing oil, you might want to double check the breather timing. excess crancase pressure will force oil out all the cracks.
Dr. Dick

Return to Big Twin Flatties

Who is online

Users browsing this forum: No registered users and 1 guest

cron
Powered by phpBB © 2000, 2002, 2005, 2007, 2012 phpBB Group.