FAQ  •  Register  •  Login

1966-73 Servi Car Electric Start System "NEW"

Moderators: Curt!, Pa

<<

Pa

Site Admin

Posts: 4679

Joined: Sun Mar 12, 2000 1:01 am

Location: Ohio USA

Post Thu Jun 23, 2005 2:44 am

1966-73 Servi Car Electric Start System "NEW"

This is a bit premature for me to release this yet folks but I just couldn't hold back anymore. In the meantime.....take a look by clicking on the link below and be sure to check back often for updates on price and availability. I can tell you this up front though. 8 units will be ready soon!! Sorry for the shameful promo. Kat will have them at Davenport. Pa

www.vtwinrebuild.com
<<

Graham

Posts: 332

Joined: Sun Dec 21, 2003 1:01 am

Location: Whitley City, KY, USA

Post Thu Jun 23, 2005 4:40 am

Pa, how about one for belt drives??
Graham
<<

Pa

Site Admin

Posts: 4679

Joined: Sun Mar 12, 2000 1:01 am

Location: Ohio USA

Post Thu Jun 23, 2005 4:48 pm

That is the next project on the list Graham. Pa
<<

Pa

Site Admin

Posts: 4679

Joined: Sun Mar 12, 2000 1:01 am

Location: Ohio USA

Post Thu Jun 23, 2005 6:48 pm

I will be taking them soon and will post them for all to see. We haven't decided on a back ground color for the photos yet and these photos will be used in the marketing of it. I want blue or orange. It's coming down to the short and long straw decision method I guess. LOL!! Pa
<<

Graham

Posts: 332

Joined: Sun Dec 21, 2003 1:01 am

Location: Whitley City, KY, USA

Post Thu Jun 23, 2005 8:06 pm

Pa, I would think that an orange background would make the parts "pop" more than the blue...less blending of shadow or dark colors of parts. Unsolicited graphic design advise!!
Graham
<<

sleeper

User avatar

Posts: 1538

Joined: Thu Jun 19, 2003 12:01 am

Post Fri Jun 24, 2005 2:30 am

Kind'a had a hunch this was coming!!
Very Good News.. I like that ya can just get 1 part if that's all ya may need.
It's ALL good!!
Add the belt drive set-up for E start.Cool

One thing that not many belt drive makers do is have many different front pulleys, usually only a couple different sizes.
We'll see..
<<

Pa

Site Admin

Posts: 4679

Joined: Sun Mar 12, 2000 1:01 am

Location: Ohio USA

Post Sat Jun 25, 2005 12:50 am

I like the orange better for the same reasons Graham. The color keeps the system in the HD arena somewhat also.

Thanks Billy... The solo system has been a stinker for us though. We attempted to mount the first complete sytem on a solo and the darn solenoid hits the rear tire without the fender on. We couldn't even bolt it down because of this. Since the design is original it mounts easily on the servi car and the solenoid is pointed betweens two wheels instead of directly at just one wheel. We now have to run a line of different tops that will hold the soleniod up and away from the rear tire so the system can be used on the solo. Not a big deal but it did catch us off guard unexpectedly. The earlier 64-65 wasn't a problem as far as mounting it on a solo goes because it didn't use a solenoid type setup for starter gear engagement like the later more reliable 66-73 system. We decided to reproduce the later system for this reason. I am just so glad that folks will never have to pay out the #@% again for an old worn out system which ends up being in need of many very hard to find replacement parts that cost a bundle also. Not only will Kat be offering complete systems but she will also be offering individual replacement parts for rebuilding and repairing originals. The belt drive units are a ways away yet but they definately are to become a reality. Got to finish up what we started before moving on to them first though. I will keep you all posted as things progress. It has been in the works for over a year now and all are finally materializing at a much faster rate than we ever expected them too. We thought this should have been done years ago and now it is for real!! YAHOOOOOOOOOO!!!!! LOL!!! PA

Return to Servi-Cars

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007, 2012 phpBB Group.