FAQ  •  Register  •  Login

Gas tank

Moderators: Curt!, Pa

<<

pressman

Posts: 28

Joined: Thu Sep 28, 2000 12:01 am

Location: Texas City ,Tx

Post Sat Jul 13, 2002 10:54 am

Gas tank

Picked up a set of tanks for my 45' the other day,and someone in the past has kreemed the gas side tank. The problem is,when i look inside the tank from the filler neck,around the outlet there are cracks in the kreem,just in that one area,does anyone here have any suggestions?,also i'm not wild about the through the tank gas shutoff,anyone here done away with that?
<<

49WL

Posts: 188

Joined: Tue May 30, 2000 12:01 am

Location: Charlottesville, VA

Post Sat Jul 13, 2002 11:48 am

Although I now use the original through the tank shut-off valve and steel gas line (it works fine) when I was first getting the bike running, I bought two adapters (7/16-20")from "45" Restoration to fit a rubber hose between the tank and gas filter. I put a small petcock in the line, and it worked great.
<<

pressman

Posts: 28

Joined: Thu Sep 28, 2000 12:01 am

Location: Texas City ,Tx

Post Sat Jul 13, 2002 11:57 am

What about the hole in the top of the tank?...any suggestions there?....not really wanting to be too anal about being original.
<<

49WL

Posts: 188

Joined: Tue May 30, 2000 12:01 am

Location: Charlottesville, VA

Post Sat Jul 13, 2002 2:50 pm

I just left the rod and knurled shutoff rod in the tank (in the on position), but You could leave the rod out, and just use the knurled knob with a nut/bolt in the hole. You will need to use the bottom gas shut off rod end because that is what the rubber hose adapter screws on to.
<<

pressman

Posts: 28

Joined: Thu Sep 28, 2000 12:01 am

Location: Texas City ,Tx

Post Sat Jul 13, 2002 3:58 pm

I'm looking at the bottom of the tank,at the outlet it os a brass fitting with 3X4 on it(assuming that's 3/4)...someone has put a bit of bondo here around the fittng,i suspect maybe the area has been repaired,am going to flake all the bondo away i can to get a better idea of what's there...
<<

JHDIronRide

Posts: 234

Joined: Sun Feb 10, 2002 1:01 am

Location: Saco, Maine USA

Post Sun Jul 14, 2002 5:06 pm

Hey Press, Id be careful in that area, is your tank leaking?? sounds like at one time it was, I had same situation with mine, had all kinds of slop around fittin, developed a leak, had to chip away, replaced fittin, and went with in line filter ,rubber hose, luckily, after quite bit work, stopped leak, saved original tank, reprimed and saved most of paint. think im gonna stay with this set up , workin good now.
<<

pressman

Posts: 28

Joined: Thu Sep 28, 2000 12:01 am

Location: Texas City ,Tx

Post Sun Jul 14, 2002 9:16 pm

Finally chipped all the bondo away....seems the tank is cracked around the large drain plug(?)in the bottom of the tank,and has a couple of pinholes up around the shiftet handle bracket,i can't see any leaks or holes around the main outlet fitting...and i'm not sure if they were leaking or not,working on getting a rolling frame going here
<<

HOOTER

Posts: 1319

Joined: Sun Feb 25, 2001 1:01 am

Location: State College, Pa.

Post Mon Jul 15, 2002 6:44 am

Better check all your mounting points too. Almost sounds like this thing may have been a total rust bucket. Try to find out if your surfaces have been thinned.

HOOT
<<

pressman

Posts: 28

Joined: Thu Sep 28, 2000 12:01 am

Location: Texas City ,Tx

Post Mon Jul 15, 2002 9:55 am

all thew brackets seem to be fine,the tank seems sound everywhere but the one spot aound the tank bung...seems i'll have a better picture when i try to dissolve the kreem thats in the tank now with some acetone.once i do that then i can get a better idea what i'm up against.

Return to 45 Flatties

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 2 guests

Powered by phpBB © 2000, 2002, 2005, 2007, 2012 phpBB Group.