Board index Flathead Power-Technical Questions, Answers, and Suggestions Knuckles electrical problem

electrical problem

Moderators: Curt!, Pa

Post Tue Jun 17, 2008 10:36 am

Posts: 29
Location: Boston, MA
I have 47 knuckle with the 3 brush 6 volt system

I came out of a local establishment, to find my ignition in the on position. i'd like to think i know how to shut off my own bike, but who knows.....

after jump starting bike, it missed and farted all the way home. I found I had to shift up just to keep it going. I checked the ignition points and they were not burnt out, the battery is ok, I have power to the ignition terminal and I did replace the relay thinking that was the problem.

but it's not. the bike will not start. the gen light comes on, but after many kicks, nothing.

could the generator be shot from either the ignition being on and/or my jump starting it?

I should add that the mike has about 600 miles on it, that I have accessory lights under the seat and tend to run during the day with the headlight on for safetey reasons. Then I read in Palmer's book that extensive use of the headlight could run the generator down as it does not charge quickly enough

Post Tue Jun 17, 2008 4:27 pm

Posts: 377
Location: madison wisconsin usa
try 2 things:

1 fully charge the battery and try again to see if it still misses. or even starts.

2 if it still misses/will not start with a full battery, change the condensor.


ps, throw a set of fresh plugs in it before you do anything, i guess that makes 3 things!

Post Wed Jun 18, 2008 8:15 pm

Posts: 1642
Location: Interlaken, NY USA

Hey 42K42, Do the stuff John suggested, re charge battery, etc. I'd bet on the condenser being the problem, although usually it's the points that take it when the switch is left on. Good luck.
Keep us posted,

Return to Knuckles