Board index Flathead Power-Technical Questions, Answers, and Suggestions Knuckles Electrical Problem

Electrical Problem

Moderators: Curt!, Pa

Post Mon Jul 14, 2008 8:55 am

Posts: 29
Location: Boston, MA
This is a new problem, from my a previous post, with another bike.

The bike will shutt off while running when I switch the lites on. So, I'm thinking there must be a short somewhere bewtween the ignition switch and the head light. But everything seems to be ok.

Any thoughts?


Post Mon Jul 14, 2008 10:03 pm

Posts: 2677
Location: Los Angeles, CA
Could be a short in the tail lamp too :mrgreen:

Post Tue Jul 15, 2008 8:00 pm

Posts: 377
Location: madison wisconsin usa
bad switch?


Post Wed Jul 16, 2008 12:40 am

Posts: 693
Location: somerset, oh usa
If using a stock switch it could be that it just needs used. Will it not run at all with the lights on or will it just die when monkeying with the switch?
Clean the contacts and bar under the switch. Or normal use will relieve the problem if so.

Post Wed Jul 16, 2008 12:53 pm

Posts: 43
Some [most] aftermarket switches have too much play in them and will kill the bike at idle when switching from ignition to light position. They will also try to kill the motor as you are running down the road. If you are able to avoid the engine stopping by quickly changing switch positions, that is your problem.
PS, the H-D eagle iron ign switch is worthless, also.

Post Thu Jul 17, 2008 1:15 pm

Posts: 29
Location: Boston, MA
I thought I had posted a reply but see it is not listed

I had been having other electrical problems with this bike and assumed the worse. But when starting from the beginning, it seems one of the screws on the terminal tab loosened up. I have to remember to keep things simple before worrying about larger problems


Return to Knuckles