FAQ  •  Register  •  Login

Repro piston groove problem

Moderators: Curt!, Pa

<<

hans56kh

Posts: 54

Joined: Mon Dec 13, 2004 1:01 am

Post Thu Apr 12, 2012 6:36 am

Repro piston groove problem

I found a problem on a new piston. I do not know the brand but it has a sign cast in, on the inside. It is a circle with a horizontal line inside and a somewhat larger circle around it not, centred but tangentially touching, making what looks like a partial solar eclipse or a 3/4 dark moon. Anyone who knows this brand?
The oil control ring has an expander. When I tried to push this ring in the groove, it required tremendous force. Definitely not good. It looked like the groove was possibly not deep enough. I then compared things with a 40 year old Bohnalite piston, put on NOS HD rings and found that things looked fine. Measured the groove depth and found that it was 1 mm (.04") deeper in the old piston which explained everything. (Rings and expander were the same design on both pistons.) Has anyone seen this type of problem before?
<<

Samsup

Posts: 125

Joined: Wed Feb 25, 2015 2:35 pm

Post Sat Mar 07, 2015 3:01 pm

Re: Repro piston groove problem

can it be an oversize piston?
<<

Cotten

User avatar

Posts: 2898

Joined: Thu Sep 30, 1999 12:01 am

Location: Central Illinois, USA

Post Sat Mar 07, 2015 5:16 pm

Re: Repro piston groove problem

Hans!

Its been a few years, but I always found those pistons to be quite precise.
I would suspect the rings to be a miss-match first.

Cutting a ring-land deeper is no big deal, but would only do it if proper rings were not available.

The more prevalent problem is too much ring drag, which can only be measured after installation:
ringdrag.jpg

A simple bathroom scale will determine the drag, but the spec is something I must leave to others...

....Cotten

Return to K-Models

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007, 2012 phpBB Group.