Board index Flathead Power-Technical Questions, Answers, and Suggestions Pans Loss of oil pressure

Loss of oil pressure

Moderators: Curt!, Pa

Post Mon Jun 23, 2008 7:06 am

Posts: 2
Location: Norway
After totally rebuilding of the engine, with all new bearings and shafts, I've got a nice oil pressure. BUT after 5 miles/hot engine there are nothing left........
Can't find any leaks internal or external. Disasembled oil pump twice, and nothing changes.
What to do to go more than 5 miles?
There are solid lifters, and clerence for tappets are within service limits.
Anyone?? Please! :cry:

Post Mon Jun 23, 2008 10:12 am

Just a guess? Relief valve is sticking.

Post Mon Jun 23, 2008 1:55 pm

Posts: 43
Too much clearance between the pinion shaft and it's bushing will cause the drop in oil pressure you describe. To a lesser degree, so will a sloppy rod set. I have seen people bypass this problem with a new S&S oil pump, not fix, bypass.

Post Tue Jun 24, 2008 3:37 am

Posts: 2
Location: Norway
Thanks for good advice. The relief piston an spring is new, so I guess they are OK.
I check the bushing last evening, and when I measure inside it may seems little eliptic.
Any problem to get the new one aligned to the shaft? Difficult reaming?!
Wondering if i make a small grove inside, and add an O-ring?
Bushing seems a bit thin.... :?

Post Tue Jun 24, 2008 5:51 am

Posts: 2677
Location: Los Angeles, CA
With the engine hot and running remove your dipstick. Stick your finger in the hole over to the return line. If you have oil flowing your engine is fine. Panheads and Knucks were not designed to show pressure when hot. Just enough to circulate the oil is all that is needed.

Post Mon Sep 08, 2008 7:26 pm

Posts: 646
Location: Detroit
I have a better idea. Remove the return line and fasten a length hose over it with a hose clamp. Aim it at a can and then see if it shoots HOT OIL into the can, NOT on your fingers.
New Knuckleheads? Thank, you, Jesus!!

Return to Pans